Skip to main content

Browser requirements

Supported browsers

To maximize your Internet banking experience and for your Internet security, we recommend using the latest supported browsers. Please note that we do not support beta or test versions of browsers.

  • Google Chrome: This website supports the current version of Google Chrome and the version previous to the current. 
  • Mozilla Firefox: This website supports the current version of Mozilla Firefox and the version previous to the current. 
  • Safari: This website supports the current version of Safari and the version previous to the current. Note that Safari is intended to be used only on Apple devices.
  • Microsoft Edge:  This website supports the current version of Microsoft Edge or the version previous to the current. 
  • Internet Explorer: While this website supports version 10 of Internet Explorer and the current version 11 (using Windows 10.1809), we recommend you use Google Chrome for an optimal experience.

Please note that in downloading the supported browser, you acknowledge that these are third-party sites. We cannot take responsibility for the consequences of you downloading browsers.

SSL encryption

To access our services, your browser must also support 128-bit Secure Sockets Layer (SSL) encryption. All the browsers we support meet this requirement. If yours doesn't, please download the appropriate encryption support from your browser's supplier.

Cookies

To use our online banking services, you must enable your browser to accept cookies. Detailed information on our use of cookies is available in our Privacy Statement. For more information on enabling and disabling cookies, please refer to your browser's Help section or documentation.

JavaScript

To use our online banking services, you must change your browser and/or device settings to enable JavaScript. For more information on enabling JavaScript, please refer to your browser's Help section or documentation.